dualathlonserver.com

Home > Sharepoint 2010 > Sharepoint 2010 Soap The Server Returned A Non Specific Error

Sharepoint 2010 Soap The Server Returned A Non Specific Error

The very annoying “The server returned a non-specific error when trying to get data from the data source.” For what its worth, if you create a site that uses classic mode more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Take a look at line 3 in particular. Search for 6. http://dualathlonserver.com/sharepoint-2010/sharepoint-2010-the-server-returned-a-non-specific-error.php

This is with in the webpartpage. I've tried every combination with "some success". First up, go back to the SOAP data source in SPD  and have a look at the “Login” tab of the data source properties. Tuesday, November 29, 2011 10:18 AM 0 Sign in to vote You are my hero! http://www.iotap.com/blog/entryid/69/getting-rid-of-ldquo-the-server-returned-a-non-specific-error-rdquo-in-sharepoint-designer

I have tried the suggestion from here http://blogs.msdn.com/sharepointdesigner/archive/2008/06/20/data-source-issues-and-workarounds.aspx but I still get the error Here is my web service XML file after modifying it.Webs on mvm-001

This was particularly frustrating because I was trying to give a Web Services demo for a class I was teaching on SharePoint Designer and kept running into this roadblock. ModuleName: SPRequestModule Notification: 2 HttpStatus: 401 HttpReason: Unauthorized HttpSubStatus: 0 ErrorCode: 0 ConfigExceptionInfo: Notification AUTHENTICATE_REQUEST ErrorCode: The operation completed successfully. (0x0) Thanks for reading… Paul Culmsee www.cleverworkarounds.com Print PDFNo TagsSend to By linking multiple data sources, you create a single data source that appears in the Data Sources list with all of your other data sources. SharePoint Development & Ops Developer's blog related to SharePoint, ASP.NET and JavaScript Home About SharePoint Designer - Server Returned a Non-Specific Error in SharePoint 2007 Nothing is more frustrating that trying

Friday, August 05, 2011 6:25 PM 0 Sign in to vote Copying the Data Source and removing any calculated fields fixed the error for me. Posted by Vimlesh at 01:19 Labels: Sharepoint Designer 3 comments: mooti said... Check the format and content of your query and try again. why not try these out So an example would be: http://10.0.1.15/_vti_bin/usergroup.asmx?WSDL So if you got as far as the above, you'll find that the web service will still not work.

Upon refresh, sometimes the DVWP will render or it will puke with that annoying error message. Microsoft has a KB article describing the setting and why it was put in. In fact, my environment was totally virtualized and I was working on a stand alone installation of MOSS. http://sharepointgeorge.com/2009/display-sharepoint-list-site-data-view-web-part).

  1. But when I click "Show Data", it returns the generic message stating: "The server returned a non-specific error when trying to get data from the data source...".
  2. Leave a Reply Click here to cancel reply.
  3. Your help will remove my headache.
  4. I have no explaination for why, but it worked for me.
  5. Subscribe Newsletters Search This Blog Loading...
  6. Join them; it only takes a minute: Sign up “The server returned a non-specific error when trying to get data from the data source” in Sharepoint Designer 2007 with SOAP web
  7. Check the format and content of your query and try again.
  8. Sunday, January 10, 2010 7:57 PM 0 Sign in to vote >Brilliant!
  9. I cant able to create Data View Webart using SOAP service data source.
  10. Go to Insert - New Item Form 2.

Proposed as answer by PbFred Monday, November 10, 2008 11:07 PM Unproposed as answer by Mike Walsh FIN Thursday, February 05, 2009 5:23 PM Monday, November 10, 2008 11:07 PM 0 More hints Now replace the existing "Datasources" section with selected one.7. All Rights Reserved. Name (required) Mail (will not be published) (required) Website Current [email protected] * Leave this field empty Notify me of follow-up comments by email.

Excel Cannot Connect to SharePoint List As I am working in SharePoint support, I come across so many issues on day 2 day basis and always try to share with all this contact form SSH makes all typed passwords visible when command is provided as an argument to the SSH command What to do when majority of the students do not bother to do peer If the problem persists, contact the server administrator" when trying to use a data view web part to display an XML Web Service with SPD.The web service connects OK but when I This sort of entry is actually very common in IIS logs because of the way windows authentication works in IIS.

The field in question's data type was "Number". Follow by Email Archive ► 2016 (14) ► 01/24 - 01/31 (3) ► 01/17 - 01/24 (10) ► 01/10 - 01/17 (1) ► 2015 (2) ► 07/05 - 07/12 (2) ► So instead of deploying it to the GAC, you opt to deploy it to bin folder of the web application and give it a partial trust level instead. have a peek here Once I removed that portion of the statement as you mentioned in your post, IT WORKED!!

Reply Leave a Reply Click here to cancel reply. That way when requests are made to access the webservice, these credentials will be used. Among other things, being able to specify a particular view on a list when calling the GetListItems method is really handy.

The final thing you have to remember is within the Data Source Properties window, click on the Login tab.

Tried another server, server B,and it worked fine. Required fields are marked *Comment Name * Email * Website Notify me of follow-up comments by email. In each site I then added a single item to the built-in links list that you get with the Team Site template… Then using SPD, I then created a Data Source Replace the datasource element of the erroneous dataview with the copied datasource element TAGS: Sharepoint Designer Share this post « Productizing Add-ons and Solutions for Dynamics CRM.

asked 4 years ago viewed 433 times active 3 years ago Related 1Problem with DataView web part and Server-side script datasource from RSS0How do I get sorting to work in the Thanks for posting! Lesson 2: SharePoint keeps its own list of trusted CA's, in addition (and different) to those that Windows manages in its certificates store What I was trying to do First off, Check This Out Notify me of new posts by email.

In the Configure Database Connection Wizard, after entering the servername, userid, password, and clicking next, I selected AdventureWorks, and clicked thespecify custom Select, Update, Insert, and Delete radio button. If the problem persists, contact the server administrator. When I try to connect it via SPD, it shows connection successful. So I installed SPD on the box inside the facility and set up the data view and it works fine when viewed through a remote console session on that box.  Outside though (through

template. So another alternative is to add credentials to the secure store for the data source and use them in the login tab. Not the answer you're looking for? Thanks much for provising this simple solution!

Tuesday, October 13, 2009 4:58 PM 0 Sign in to vote Tim,Were you ever able to locate a solution to this issue you have regarding SPD and showing data from a Marked as answer by Mike Walsh FIN Saturday, December 31, 2011 7:13 AM Tuesday, May 17, 2011 2:44 PM 0 Sign in to vote I got this error while learning about I am going to do more testing on the schema and rolls of the logins and how they impact Sharepoint Designer. shereen August 27, 2009 at 3:18 pm # Hi brisyb, I've not actually encountered a problem with custom lists, only the web services themselves.

Troubleshooting Alas, I did the following… Using the trusty ULS Log Viewer (http://code.msdn.microsoft.com/ULSViewer), I detected that "the root of the certificate chain is not a trusted root authority" occurred whenever I After all, SharePoint by default does not have anonymous access enabled, and I am performing the above steps logged in as an administrative account. I was then able to get it working on a database on the same server. As stated in the above article “This issue occurs because of an error in the ASP.NET 2.0 authentication component.

You can even link data sources of separate types -- for example, you can link an XML file to an SQL database. So what gives with these two claims authentication web applications?

>